New editor bug: Unable to get new edited base to apply

Discussion in 'Build Bugs' started by Piratepup, May 8, 2016.

  1. Piratepup

    Piratepup Powder Monkey

    I have the iPhone 4s and I updated the game and used the new editor layouts to edit a new base. I love it, I was able to edit and make a cool base set up.
    The problem I am having is that this new layout will not stay applied. When I go and click apply layout it asks me if I am sure I want to apply and it will erase my old layout. I select yes. It then seems to apply the base, cool beans. The problem is that it really did not apply the new base because when I log out and log back in my old base set up is still active. I also tried to apply my new base set up then in the other editor slot I tried to import the "live" set up I just applied. Instead of doing that in imports my old base set up.
    So basically the issue is the new base set up I want to apply was never applied even though it shows it did apply it.
    How do I fix this issue, is this a known bug?
    Things to note:
    I have cleared out all obstacles (rocks and such)
    I have placed everything I have on the map in my new layout.

    At this point the new layout is useless because it will not apply the new base set up. Something is not registering in the game because it shows that it is applying it when it isn't so it isn't updating a file or something.
    Any advise on how to fix this?
  2. Skye

    Skye Commodore

    The current problem known with it was because of uncleared rocks, but since you said you cleared them all, I'm unsure what could be happening. There is a bugfix coming very soon which may hopefully fix the problem.

    I suggest sending in a ticket with the in-game support button so they get info to check your island to see what is going wrong. It will certainly help them identify what is happening much quicker, as it appears different from the currently known bug. @Lynsey [Midoki] will probably suggest doing that.

    If your new layout is at least saved in the editor, hopefully it will be able to safely apply when the bugfix is released.
  3. Piratepup

    Piratepup Powder Monkey

    The issue was fixed with the update today. Everything is now working properly :)
  4. awbo

    awbo Captain

    I am experiencing this problem since the latest update. Went to layout 1. Used store all, no rocks on my island. Created new base. Hit apply. All fine. Then while in base mode I made a couple of little tweaks. Thought, I should save that. Went to layout 1 where I could see my new layout (minus the tweaks I had just made). Hit import and it loaded my old base design! So now I am sitting here looking at my new base but I can't bloody import it! So frustrating!
  5. awbo

    awbo Captain

    Update: so I exit game and when I go back it takes me straight to layout editor (with my old base), tells me I have some overlapping elements and they need to be fixed. My tavern and a decoration were in storage. So I placed them, hit apply and it warns, this will overwrite your layout, I choose yes, because there is no other option, it funnelled me into this choice. So now I have my old layout, one hour of life wasted. Guess I will keep my corner layout (sigh).

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice