1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Latest update issues.

Discussion in 'General Discussion' started by Intimidator, Mar 12, 2018.

  1. Intimidator

    Intimidator Captain

    There is no update in the App Store. When I try to load the game it tells me to update. I hit the update button that forwards me to the App Store but nothing to update again. I can’t send an in game ticket (no access to my account). Restarted my device and still nothing. Using IPad Pro running iOS 11.2.6 latest version.
  2. Lynsey [Midoki]

    Lynsey [Midoki] Senior Designer Staff Member

    Unfortunately this is an issue with the AppStore not refreshing on your device (the update is available in all territories) - we're not sure what causes it, or why it affects some players and not others, and t's not exclusive to our game (I've had it with quite a few other games as well - it is very annoying!).

    You could try force closing the AppStore (double tap the home button and swipe it to close). If that's still not sorted it, then unfortunately the only way to resolve it quickly is to uninstall and reinstall - however, this will give your account a new device ID, so if you're playing on two devices, you may want to hold off updating the second for 48 hours to avoid the multiple device Plunder Points penalty.
  3. Intimidator

    Intimidator Captain

    I forced close the App store just now and tried again. Still a no go, so I will have to delete/reinstall. I have had to do this quite frequently when an update drops. I was curious if it was something I was doing wrong before I did it again. Deleting and reinstalling usually does the trick. Luckily I only play one account on one device now so not worried about the pp penalty. Ty @Lynsey [Midoki]
  4. Floki

    Floki Captain

    Can't get in either......Me thinking ahhh they finally locked me out...
  5. Lynsey [Midoki]

    Lynsey [Midoki] Senior Designer Staff Member

    You can also check the updates tab at the bottom of the AppStore - sometimes the update will be listed there, but not when you go to the listing (either directly through the game, or via a search).
  6. 850arrr

    850arrr Captain

    I had the same problem going to the app store via the update button from the game prompt. Double tapping the home button, swiping up to close the game and app store apps, go back into app store, tap the update button, swipe down to refresh and the plunder pirate update showed up. I've had to do this with I believe every update.

    **edit** this was on my iPhone 6
    Last edited: Mar 14, 2018
    Mocon and Intimidator like this.

    WOLLIMAUS First Mate

    That worked for me too!!! Right after the update was available :) but i didn't close app store again, i just tapped the update button, the icon down there on the right side and waited for a few seconds and tadaa the update showed on my list
    Last edited: Mar 12, 2018

Share This Page