Is something wrong?

Discussion in 'General Discussion' started by ⚡️✨seawitch✨⚡️, Jun 26, 2020.

  1. I keep getting kicked off the game. When I get on I ask for guild ship troops and nothing comes up in chat so I try again, and it wants 10 gems (insert angry face). This is taking up my event time.
  2. 850arrr

    850arrr Captain

    Sounds like a connection issue, is your WiFi ok? Try rebooting your modem and router to see if it improves.
  3. It kept saying maintenance in progress. Luckily it resolved after this happening about 4-5 times
  4. Hawkbeard

    Hawkbeard First Mate

    my game only works on wifi, every time its just 4g then the game will not work it wont download assets or it just hangs on connecting to server. Deleted the game off my phone and added it again to no avail, anyone else having this issue or know how to fix it? failing that @Lynsey [Midoki] do you know what could be causing it?

    ps. latest iphone software version 13.5.1 using iphone xs
  5. Silky

    Silky Powder Monkey

    Hi Hawkbeard, I have this exact issue. Can log in only on WiFi. Never used to be an issue to access game on 4g now I just continually get a downloading assets error. I have tried deleting and reloading app, clearing cache but still no luck. Prevents my participation when I am out and about

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice