1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Download failed because you may not have purchased this app"

Discussion in 'Build Bugs' started by Broadside, Dec 14, 2016.

  1. Broadside

    Broadside Crew

    I successfully installed the new version of the app, was able to link it using the code (wasn't sure about the google linking so followed what I understood the instructions were). I was able to log into my account, all fine. Logged out, switched user, attempted to do the same with the alternate user: the updated logo appeared but it wouldn't launch. While it appears that the app is installed for all profiles, the app gives the error on launch for both my main account and the mini, "download failed because you may not have purchased this app". Rebooted phone, same errors. Nexus6 (2015). I haven't been able to find a workaround yet.

    So yeah, it's a free app so payment isn't required. The error message isn't helping at any rate. Possibly multi accounts are banned? I don't know, never did find TOS when I setup the mini during mini rumble days.
     
  2. Capt. Sharky

    Capt. Sharky First Mate

    I'm quoting another player (limux) from another social outlet (Bacon Slack channel), but this may help you:

    If you have several bases on one android tablet with several users (one base per user), first run the game on each user and write down the code you see. Then proceed following Midoki's instructions. If successful, make sure each base is logged into the google account (Log -> Settings) and wait for the game to enlist all the unlocked achievements.

    However, if you get "download error", do the following (you must already have the code from the attempt to run the game): open PlayStore and find "plunder pirates". You will see TWO versions - one with a rating of 4.4 and another one with no rating at all. Click on each and UNINSTALL, if it is installed. Reboot. Go back to Google Play and this time install the version WITHOUT RATING (this is the new one). When opened, enter the code, open your base and make sure you are logged into the PlayGames account in settings.
     
  3. Broadside

    Broadside Crew

    Thanks so much for the pointers. It is a case of being persistent then. I did recover the main account through linking with the google play account (it was linked to google before the errors started). The mini might be gone as I am still getting the error when I attempt to open the game on that account. Trying the uninstall/reboot/reinstall again now, this time I'll start with the mini.
     
    Joseph Fonte likes this.
  4. Broadside

    Broadside Crew

    Sadly I'm not getting any joy. Uninstalled on all profiles, reinstall new app on one, connect it to the relevant base and the relevant google play. When I attempt to install on other profile it gives the error. Both accounts have been individually connected to play in the new app, but each time I login to the alternate I lose access to both accounts with the error above. At least for the moment I know that they're out there in the ether somewhere and I won't simply lose the account forever (yet).
     
  5. LIMUX

    LIMUX Powder Monkey

    Hello, I am the one quoted above. Unfortunately, it seems there is a real problem with 2.8 release on android. If you only have ONE account and one base, - no problems. If you experience errors like described above by "Broadside", try the following steps:
    - uninstall PP
    - go to Settings -> Apps -> Google Play Services and delete cache (I would also delete data - it will simply prompt you to re-enter e-mail when you try to open Google Play)
    - reboot to recovery mode (google how to do it for your device) and wipe cache partition (don't worry - all data are safe)
    - reboot and try to install again

    The PROBLEM: Multiple user accounts (Android Tablets only)
    Basically, you can install v 2.8 only on one of the accounts (not only owner). An attempt to install to other accounts fails with "Download failed because you may not have purchased this app" error. Previous v 2.7 worked just fine. I wish we could download APK+OBB data file for the game and install manually. The problem is not connected to a specific android - I tried lollipop and marshmallow on Samsung Galaxy Note 10.1. Any help from developers will be greatly appreciated.
     
    Joseph Fonte and Broadside like this.
  6. Broadside

    Broadside Crew

    I'm still getting the error since today's update. Perhaps there might be another workaround, I've not found it.
     
  7. peg-brain bob

    peg-brain bob Captain

    I assume that the devs have simply made the game behave the same on both Apple & Android... (this 'feature' has never been available on Apple).

    I.e. you can use multiple accts by logging out of one Game Center/Google Play acct & logging on as different user - but you just cannot install/load multiple instances of the game simultaneously.
     
    Joseph Fonte likes this.
  8. Broadside

    Broadside Crew

    The nature of the error message indicates that it's a bug. The update notes indicate that various GoogPlay bugs were intended to have been addressed this update but didn't specify which. This is one that may have been targeted but is still a problem for me.
     
  9. LIMUX

    LIMUX Powder Monkey

    it is a bug (still in the current version), but I found a way around it and now happily run 4 accounts on a single Android tablet. It does not involve rooting or anything of the kind. DM me on slack if you need technical details.
     
  10. Broadside

    Broadside Crew

    Just post it here plz. Or pm.
     
    Joseph Fonte likes this.

Share This Page