Cannot create a brotherhood

Discussion in 'Guild Bugs' started by Sietes, Apr 26, 2015.

  1. Sietes

    Sietes Powder Monkey

    Ahoy pirates!
    First of all, Im using a BQ Aquaris E5 HD, running version la 4.4.2.
    Thing is simple: 100.000 gold disappear everytime i create a brotherhood! I got everything filled up, i clicked "accept" and it always shows the same error: "fill up fue descrption of the brotherhood".
    Boom! window closes and gold banish! (Already tried 3 times!)

    Thanks for your time!
  2. Ian

    Ian Commodore

    Hi Sietes,
    I would contact they should be able to resolve this for you.
  3. Christy

    Christy Commodore

    Ok dumb question but what is a brotherhood :oops:
  4. Ian

    Ian Commodore

    Secret all-male guild?
    Christy likes this.
  5. Tex

    Tex Commodore

    I think the problem is you're playing the wrong game. Plunder Pirates calls it a guild.
    Christy likes this.
  6. Bear

    Bear Commodore

    It might be a localization thing. Lost in translation
    Christy likes this.
  7. Sietes

    Sietes Powder Monkey

    It's a lost in translation thing. I'm playing the right game! : )

    Edit: I follow your advice Ian, thanks a lot!
    Tex and Ian like this.
  8. So mote it be

    So mote it be Powder Monkey

    Same issue here.. but support hasn't contacted me yet

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice